autoconf: fix NEEDS_SSL_WITH_CRYPTO
authorJunio C Hamano <junkio@cox.net>
Fri, 4 Aug 2006 23:33:18 +0000 (16:33 -0700)
committerJunio C Hamano <junkio@cox.net>
Fri, 4 Aug 2006 23:33:18 +0000 (16:33 -0700)
NEEDS_SSL_WITH_CRYPTO means you cannot just say "-lcrypto" to
use SHA1 stuff, but need to say "-lcrypto -lssl".

Signed-off-by: Junio C Hamano <junkio@cox.net>
configure.ac

index 9ce00e9..fea18b6 100644 (file)
@@ -154,8 +154,8 @@ AC_MSG_NOTICE([CHECKS for libraries])
 #
 # Define NO_OPENSSL environment variable if you do not have OpenSSL.
 # Define NEEDS_SSL_WITH_CRYPTO if you need -lcrypto with -lssl (Darwin).
-AC_CHECK_LIB([ssl], [SHA1_Init],[],
-[AC_CHECK_LIB([crypto], [SHA1_INIT],
+AC_CHECK_LIB([crypto], [SHA1_Init],[],
+[AC_CHECK_LIB([ssl], [SHA1_Init],
  [GIT_CONF_APPEND_LINE(NEEDS_SSL_WITH_CRYPTO=YesPlease)],
  [GIT_CONF_APPEND_LINE(NO_OPENSSL=YesPlease)])])
 #