require_work_tree broken with NONGIT_OK
[git/git.git] / git-sh-setup.sh
index 7bef43f..d278941 100755 (executable)
@@ -59,7 +59,7 @@ cd_to_toplevel () {
 }
 
 require_work_tree () {
-       test $(git rev-parse --is-inside-work-tree) = true ||
+       test "$(git rev-parse --is-inside-work-tree 2>/dev/null)" = true ||
        die "fatal: $0 cannot be used without a working tree."
 }