git-p4: Fix sync errors due to new server version
[git/git.git] / contrib / fast-import / git-p4
index d1512e0..e7c4814 100755 (executable)
@@ -1037,7 +1037,7 @@ class P4Sync(Command):
 
             if includeFile:
                 filesForCommit.append(f)
-                if f['action'] not in ('delete', 'purge'):
+                if f['action'] not in ('delete', 'move/delete', 'purge'):
                     filesToRead.append(f)
                 else:
                     filesToDelete.append(f)